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Introduction

CamLock for Android ensures the privacy and security of the premises by blocking the

camera usage of the employees’ devices.

This guide will help the administrators to understand how to install and launch CamLock

for Android, restrict access to the device's camera, and more.

Supported devices

● Android version 7.0 (Nougat) and above

Key Features

● Restrict access to the device’s camera

● Restrict the user from uninstalling CamLock Agent

● Restrict access to the device’s camera when it enters a specific location

● Restrict access to the device’s camera during a specific period of time
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Prerequisite

Enable Things Gateway

Using Enable Things Gateway admins can enroll/manage the Things devices in the

SureMDM web console. Admins must enable the Things Gateway and set the gateway

password in order to enroll the Things devices.

Follow the below steps:

1. Login to the SureMDM web console.

2. Navigate to the Settings > Account Settings > Things Management.

3. On the Things Management screen, select Enable Things Gateway.

4. Enter the required gateway password and click Generate Password.

5. Click Save to save the configuration.
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Getting Started with CamLock

CamLock can be downloaded from the Google Play Store. Click the link below to

download the CamLock for Android.

● Google Play Store

Launch CamLock

To launch CamLock, follow the below steps:

1. Tap the CamLock icon to launch.

2. On the CamLock welcome screen, tap Get Started.

3. Read and accept the CamLock Terms of Use.

4. Select all the permissions on the CamLock Permission Checklist screen and tap

Continue. To know more about CamLock Permissions, see CamLock Permissions

Checklist.

CamLock Home Screen will appear.
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Enrollments

The CamLock installed devices can be enrolled in SureMDM using the following enrollment

methods:

● Manual Enrollment

● Scan QR Code Enrollment

Manual Enrollment

To enroll the CamLock installed Android devices in the SureMDM web console, follow

these steps:

1. Launch the CamLock application on the device.

2. Select all the permissions and tap Continue.

3. On the CamLock home screen, enter the Account ID, Password and tap Continue.

Note: Account ID and Password can be found in the following Paths.

● Account ID: SureMDM Console > Settings.

● Password: SureMDM Console > Settings > Account Settings > Things Management.

CamLock for Android | v1.4.13 | June 2022 6
© 2022 42Gears Mobility Systems Pvt Ltd. All Rights Reserved



4. Enter the Employee/Visitor Name and Employee/Visitor ID on the next page.

5. Once done, tap Continue.

● On the CamLock home screen, the device status will change to Online.

● On the SureMDM Web Console, the device will start reflecting under the Device

Grid.

Scan QR Code Enrollment

Scanning QR Code is an alternate method to enroll the CamLock installed devices into the

SureMDM account.

To enroll a new device using a QR code enrollment, follow these steps:
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1. Login to the SureMDM Web Console.

2. Navigate to the Enrollment > QR Code Enrollment > List View > Create QR Code.

3. On the Setup QR Code for Enrollment prompt, under the Enrollment Type tab,

a. Enter the Name of the QR Code.

b. Select the platform as Things.

c. Select the enrollment type as QR Code Enrollment and click Next.

4. Under the Configure Options tab,

a. Select the Group where the device will be enrolled.

b. Select the Device Name from one of the following:

● Set Device Name Manually

● Use System Generated Name

5. Under the Save QR Code tab, click Save.

The newly created QR Code will be listed under the QR Code Enrollment section.

6. Launch the CamLock application on the device.

7. Select all the permissions and tap Continue.

8. Tap Scan QR and scan the QR Code displayed on the SureMDM web console.

CamLock for Android | v1.4.13 | June 2022 8
© 2022 42Gears Mobility Systems Pvt Ltd. All Rights Reserved



9. Enter the Employee/Visitor Name and Employee/Visitor ID on the next page.

Note: This screen will appear only if a user selects the Set Device Name Manually option on the

Create QR Code option.

10. Once done, tap Continue.

● On the CamLock home screen, the device status will change to Online.

● On the SureMDM Web Console, the device will start reflecting under the Device

Grid.
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CamLock Agent Settings

CamLock settings provide details about the CamLock Agent application.

To access the CamLock Agent settings, follow these steps:

1. Launch the CamLock Application on the device.

2. Tap Settings on the CamLock Home Screen.

3. The following details are available in the CamLock Agent settings:

Settings Description

Employee/Visitor Name This option displays the name of the employee.

Employee/Visitor ID This option displays the employee’s ID.

Account ID This option displays the Account ID of the

SureMDM console.

Device Status This option displays the device's status as

Online/Offline.

GUID This option displays the Global Unique

Identifier(GUID) of the device.

CamLock Permission Checklist Following are the permissions available on the

CamLock Permission Checklist page:

● Configure Runtime Permissions

● Enable Background Location

● Enable Accessibility settings

● Enable Display Over Other Apps
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● Allow Modification of System Settings

● Disable Multi-Users

● Enable Location Services

To know more about CamLock Permissions, see

CamLock Permissions Checklist.

CamLock Properties This option displays the status of the following

CamLock properties:

● CamLock Agent Uninstallation

● Block Camera

About CamLock This option displays the current version and the

privacy policy of the CamLock Application.

CamLock Permission Checklist

The admins can enable/disable the permissions anytime in CamLock. The following

options are available under CamLock Permissions Checklist:

● Configure Runtime Permissions - CamLock wants to access the runtime permissions

like Camera, Location, and Storage. CamLock will not work until these permissions are

enabled.

● Enable Background Location - CamLock requires location permission to be enabled all

the time. Use this option to keep the location permission enabled all the time.

Note: Configure Runtime Permissions and Enable Background Location will be available only

on the devices running Android 10 and above.
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● Enable Accessibility Settings - CamLock requires accessibility permission to prevent

users from uninstalling CamLock Application on the device. Use this option to enable

accessibility permission on the device.

● Enable Display Over Other Apps - CamLock requires display over other applications

permission to show a lock screen over the camera when a user tries to access it. Use

this option to enable the display over other apps permission on the device.

● Allow Modification of System Settings - CamLock requires this permission to access

WiFi configuration of the device. Use this option to allow the CamLock to modify the

system settings.

● Disable Multi-Users - CamLock requires this permission to restrict users from creating

multi-users on the device. Use this option to allow CamLock to restrict multi-user

creation.

● Disable Secondary Space - CamLock requires this permission to restrict user from

creating the secondary space on the device. Use this option to disable the secondary

space on the device.

Note: Disable Secondary Space will be available only on the Xiaomi devices and devices with

secondary space.

● Enable Location Service - CamLock requires location service to be enabled on the

device for the Geo Fence Job. Use this option to enable the location service on the

device.
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CamLock Properties

CamLock Properties allows users to restrict the access to device camera and restrict users

from uninstalling the CamLock application on the device when an employee enters the

premises.

To access the CamLock Properties, follow these steps:

1. Login to the SureMDM web console.

2. Select the device enrolled by the CamLock application.

3. On the Things Info panel, select the following options and click Apply.

● Block Camera

● CamLock Agent Uninstallation

The CamLock Properties will be applied to the selected device.

4. Click Save As Job to save the selected properties as a job and apply it to a group of

devices.

5. Enter the Name for the job and click Save.

The newly created job will be listed in the Jobs List section.

Time Fence

Time Fence option creates a periodical fence for the CamLock devices to function in a

specified way. Admins can restrict users from accessing the device camera when the user

enters or exits the periodical fence.
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Note: Mobile Data/Wi-Fi should be enabled to create Time Fence.

To create CamLock Properties for a particular time period, follow these steps:

1. Login to the SureMDM web console.

2. Select the device enrolled by the CamLock application.

3. Select the following options on the Things Info panel and click Save As Job.

● Block Camera

● CamLock Agent Uninstallation

4. Enter the Name for the job and click Save.

The newly created job will be listed in the Jobs List section.

5. Navigate to the Jobs section.

6. Select the Things Job and click Modify.

7. Select the Time Fence option and click Edit.

8. Set the Optional Time as

● Device Time

● Console Time

9. Select Fence has two options:

● Time Fence - Enter the Start Time, End Time and select the Days

● Date Fence - Enter the Start day, Start time and End day, End time

10. Select a user from the following options, who will receive an alert when the device

enters/exits the periodical fence:
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● Device - Device user

● MDM - SureMDM admin

● Email - Recipient of the configured email address

11. Click Save.

The Time Fence with CamLock properties will be created.

12. Go back to the Home tab and select the CamLock device(s) or group(s).

13. Click Apply to launch the Apply Job/Profile To Device prompt.

14. Select the job on the Apply Job/Profile To Device prompt and click Apply.

Geo-Fence

Geo Fence option creates a virtual fence around a geographical location. Admins can

restrict users from accessing the device camera when the user enters or exits the

geographical fence.

Note: Mobile Data/Wi-Fi and GPS should be enabled to create Geo Fence.

To create CamLock Properties for a particular location, follow these steps:

1. Login to SureMDM web console.

2. Select the device enrolled by the CamLock application.

3. Select the following options on the Things Info panel and click Save As Job.

● Block Camera

● CamLock Agent Uninstallation

4. Enter the Name for the job and click Save.
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The newly created job will be listed in the Jobs List section.

5. Navigate to the Jobs section.

6. Select the Things Job and click Modify.

7. Select the Geo Fence option and click Edit.

8. In the Geo Fence screen, type the location in the Search box.

9. Click Draw a Circle (located on the right side of the map) icon.

10. Click and drag the circle at the desired location on the map. Once the location is

marked, a prompt appears with Radius, Lat and Lng details.

11. Enter the Geofence Name and click Save.

The newly created fence will be listed in the table.

12. Select a user from the following options, who will receive an alert when the device

enters/exits the fenced area:

Device - Device user

MDM - SureMDM admin

Email - Recipient of the configured email address

13. Click Save.

The Geo Fence with CamLock properties will be created.

14. Go back to the Home tab and select the CamLock device(s) or group(s).

15. Click Apply to launch the Apply Job/Profile To Device prompt.

16. Select the job on the Apply Job/Profile To Device prompt and click Apply.
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CamLock Sentry

CamLock Sentry helps admins to create a QR code with CamLock properties. Admins can

install the CamLock Sentry application on the master android device and place it on the

entry/exit points of the premises. Employees/visitors can scan the QR code using the

CamLock application to apply the CamLock properties on their device.

CamLock Sentry can be downloaded from the Google Play Store. Click the link below to

download the CamLock Sentry application.

● Google Play Store

Enrollment and QR Code generation (CamLock Sentry)

The CamLock Sentry installed devices can be enrolled in SureMDM by using the following

enrollment methods:

● Manual Enrollment

● Scan QR Code Enrollment

Manual Enrollment (CamLock Sentry)

To enroll the CamLock installed Android devices in the SureMDM web console, follow the

below steps:

1. Launch the CamLock Sentry application on the device.

2. On the CamLock Sentry home screen, enter the Account ID, Password and tap

Continue.
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3. Enter the Device Name on the next page and tap Continue.

A QR code with CamLock properties (Disabled) will appear on the screen.

To enable the CamLock properties, follow the below steps:

1. Navigate to the SureMDM web console.

2. Select the CamLock Sentry device on the device grid.

3. On the Device Info panel, select the following properties and click Apply.

● Block Camera

● CamLock Agent Uninstallation
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The CamLock Properties will be enabled on the CamLock Sentry device. Employees can

scan the QR code to apply the CamLock properties on their devices.

Scan QR Enrollment (CamLock Sentry)

Scanning QR Code is an alternate method to enroll the CamLock Sentry devices into the

SureMDM account.

To enroll a new device using a QR code enrollment, follow the below steps:

1. Login to the SureMDM Web Console.

2. Navigate to the Enrollment > QR Code Enrollment > List View > Create QR Code.

3. On the Setup QR Code for Enrollment prompt, under the Enrollment Type tab,

a. Enter the Name of the QR Code.

b. Select the platform as Things.

c. Select the enrollment type as CamLock Sentry and click Next.

4. Under the Configure Options tab,

a. Enable/Disable the following CamLock Properties:

● Block Camera

● CamLock Agent Uninstallation

b. Enter the time(in seconds) in the Refresh text field.

5. Under the Save QR Code tab, click Save.

The newly created QR Code will be listed under the QR Code Enrollment section.

6. Launch the CamLock Sentry application on the device.

7. Tap Scan QR and scan the QR Code displayed on the SureMDM web console.
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8. Enter the Device Name on the next page and tap Continue.

A QR code with CamLock properties will appear on the screen. Employees can scan the QR

code to apply the CamLock properties on their device.

Note: Admins can check the status of CamLock properties by tapping on the Properties option.
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